Issues accessing or using Microsoft 365 services in the NA region

Resolved

Microsoft has confirmed full service restoration overnight. If you are continuing to see any of the issues listed above, please report them accordingly to our Central Piedmont ITS Service Desk for assistance.
Posted Jul 24, 2026 - 09:33 EDT

Identified

Attention to all MS365 users, Central Piedmont ITS has been made aware from Microsoft support of potential service degradation across the North American region to services. At this time there is not a published restoration of services, but Microsoft is actively working to correct service issues, and we will keep all updated accordingly. For details on the service message, see below:

User impact:

Users may be experiencing issues accessing or using Microsoft 365 services in the North America region.

We've confirmed that multiple Microsoft 365 services are degraded, including but not limited to:

• Microsoft OneDrive - Access to OneDrive is intermittent.
• SharePoint Online - Error message, “Something went wrong”
• Microsoft Teams - Degraded chat functionality, including images not loading.
• Microsoft 365 Admin Center - Admin Center is loading slowly or not at all.
• Power Automate - Automate flows not loading.
• Copilot Chat - Intermittent delays or failures in any Copilot Chat action and query.
• Microsoft Loop - Unable to open or load Loop pages.
Posted Jul 23, 2026 - 15:04 EDT
This incident affected: Microsoft Services (Outlook, Teams, SharePoint, OneDrive, Copilot Chat, Microsoft Loop).