Webex Contact Center
Resolved
The Contact Center issue has been resolved.
Posted Dec 19, 2024 - 12:40 EST
Investigating
The vendor is experiencing a global issue with the Contact Center and is investigating.
Posted Dec 19, 2024 - 10:21 EST
This incident affected: Contact Center (Service Desk Phone Services, Service Desk Chat Services, Navigator Phone Services, Financial Aid Phone Services, Scholarships Phone Services).