Turnitin and Gradescope Services Down
Resolved
This incident has been resolved.
Posted Sep 16, 2024 - 08:24 EDT
Update
We are continuing to investigate this issue.
Posted Sep 16, 2024 - 08:23 EDT
Update
We are continuing to investigate this issue.
Posted Aug 30, 2024 - 13:13 EDT
Update
We are continuing to investigate this issue.
Posted Aug 30, 2024 - 11:00 EDT
Investigating
We are currently investigating this issue.
Posted Aug 30, 2024 - 10:43 EDT
This incident affected: Gradescope and Turnitin.