Phone System Down - External Calls
Resolved
This incident has been resolved.
Posted Oct 10, 2022 - 08:52 EDT
Investigating
An issue with the Phone System is currently preventing external calls from going out or coming in. ITS is investigating.
Posted Oct 10, 2022 - 08:44 EDT
This incident affected: Phones (Cisco Voice and Unified Communications).