testing again
Resolved
Our data processing infrastructure is running behind which is causing inaccuracies in the reporting tools. No data has been lost and the system should be caught up shortly.
Posted Jan 02, 2019 - 15:36 EST
Investigating
We are currently investigating this issue.
Posted Jan 02, 2019 - 15:35 EST