Cloud Login error
Resolved
This incident has been resolved.
Posted May 13, 2020 - 09:15 EDT
Investigating
Users are experiencing issues with the authentication process for the Cloud system, preventing users from accessing Cloud services. We are currently looking into the issue.
Posted May 13, 2020 - 07:22 EDT
This incident affected: CPCC Cloud.