Microsoft Outlook - Degraded Performance

Resolved

Microsoft has confirmed they're service issues are resolved.
Posted Jan 23, 2026 - 08:03 EST

Update

Microsoft has identified an issue with some Microsoft 365 services, please see this page for updates, https://status.cloud.microsoft/m365/.
Posted Jan 22, 2026 - 15:52 EST

Investigating

Microsoft has identified an issue with some Microsoft 365 services, please see this page for updates, https://status.cloud.microsoft/m365/.
Posted Jan 22, 2026 - 15:49 EST
This incident affected: Microsoft Services (Outlook).