Document Imaging Outage
Resolved
This incident has been resolved.
Posted Aug 31, 2020 - 07:36 EDT
Investigating
We are currently investigating this issue.
Posted Aug 28, 2020 - 11:31 EDT
This incident affected: Document Imaging.