Blackboard login error
Resolved
This incident has been resolved.
Posted Dec 19, 2019 - 11:57 EST
Investigating
We are currently investigating an issue where some users receive an error message when trying to login to Blackboard.
Posted Dec 19, 2019 - 10:53 EST
This incident affected: Blackboard.