Outlook Performance Issues Reported
Resolved
This incident has been resolved.
Posted Nov 26, 2024 - 16:38 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 25, 2024 - 14:22 EST
This incident affected: Microsoft Services (Outlook).