MyCollege - Slow Load Times
Resolved
This incident has been resolved.
Posted Aug 13, 2024 - 14:52 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 12, 2024 - 12:21 EDT
This incident affected: MyCollege (Self Service, Web Advisor, Attendance System).