Blackboard Outage
Resolved
This incident has been resolved.
Posted Jun 29, 2020 - 14:46 EDT
Investigating
We are currently investigating this issue.
Posted Jun 29, 2020 - 13:22 EDT
This incident affected: Blackboard.