Intermittent Service Degradation Affecting Azure-Hosted Applications

Resolved

This incident has been resolved.
Posted Jul 30, 2026 - 14:16 EDT

Investigating

We are currently investigating a network connectivity issue affecting services hosted in our Microsoft Azure environment. Users may experience intermittent slowdowns, timeouts, or errors when accessing certain applications and services. Our team is actively working with our providers to identify the root cause and restore normal service as quickly as possible.
Posted Jul 30, 2026 - 09:28 EDT
This incident affected: Microsoft Services (Azure Infrastructure Services).