Service Impacts - ImageNow Platform
Resolved
On 3/31/2022, Information Technology Services (ITS) had removed public Internet access to the ImageNow platform (eforms.cpcc.edu) and the forms on it, in response to discovered security vulnerabilities. The software manufacturer has supplied remediation and these vulnerabilities have been patched. Public Internet access to ImageNow has been restored.
Posted Apr 05, 2022 - 15:56 EDT
Identified
In response to critical vulnerabilities made public by the software manufacturer this afternoon, Information Technology Services (ITS) will be removing public Internet access to the ImageNow platform (eforms.cpcc.edu) and the forms on it. Users will be able to access this service by logging into Central Piedmont Cloud or using a computer on campus.

This will affect the ability of faculty, staff, and students to submit and edit documents processed through this service when not using a Central Piedmont networked computer. Services will be restored as soon as system security patches are available for remediation. Upon restoration of external services, additional communication will be provided.

Additional information, including other best practices documents and specific information security alerts, are available on the ITS Security website
Posted Mar 30, 2022 - 18:09 EDT
This incident affected: ImageNow.