Self-Service: Issues with specific services
Resolved
This incident has been resolved.
Posted Sep 24, 2024 - 09:44 EDT
Identified
The issue with Graduation Submission and User Profile Not loading has been resolved. The issue with Residency Tuition Submission still exists
Posted Sep 09, 2024 - 12:40 EDT
Investigating
We are currently investigating issues with graduation submission, residency tuition submission, and user profile not loading.
Posted Aug 20, 2024 - 17:41 EDT
This incident affected: MyCollege (Self Service).