Microsoft 365 Web Apps
Resolved
This incident has been resolved.
Posted Jan 29, 2025 - 16:22 EST
Investigating
Microsoft is currently experiencing issues with the Microsoft 365 for Web applications.
As a workaround, users may be able to access their Microsoft 365 applications and documents via desktop applications. Microsoft and ITS are currently working on the issue. Updates will be provided as they are available.
Posted Jan 29, 2025 - 08:56 EST
This incident affected: Microsoft Services (Bookings, Excel, OneNote, Outlook, PowerPoint, Teams, Word).