Brightspace Outage

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 09:11 EDT

Update

We are continuing to investigate this issue.
Posted Oct 20, 2025 - 12:53 EDT

Investigating

Our Brightspace instance is currently experiencing an outage/degraded performance due to an AWS outage. From the D2L status page:
"Due to the ongoing AWS outage, we are unable to scale to support increased usage. You may experience slowness or an outage until the AWS outage is resolved."
Posted Oct 20, 2025 - 09:42 EDT
This incident affected: Brightspace.