Blackboard loading slow
Resolved
This incident has been resolved.
Posted Jan 08, 2020 - 09:35 EST
Investigating
We are currently investigating an issue that is causing long loading times in Blackboard.
Posted Jan 08, 2020 - 08:26 EST
This incident affected: Blackboard.