Various System Outages

Resolved

This incident has been resolved, and the affected services should now be available.
Posted Jan 20, 2026 - 14:18 EST

Update

We are continuing to investigate this issue.
Posted Jan 20, 2026 - 08:29 EST

Investigating

We are aware of system issues with Mycollege Self-Service, Perceptive Content, Colleague, and Citrix Desktops. We are currently investigating the issues and will update once we have more information.
Posted Jan 20, 2026 - 08:26 EST
This incident affected: MyCollege (Self Service) and Colleague, CPCC Cloud, Perceptive Content.