My College - Attendance System Issue
Resolved
This incident has been resolved.
Posted Oct 14, 2024 - 16:56 EDT
Investigating
We are currently investigating this issue.
Posted Oct 14, 2024 - 11:11 EDT
This incident affected: MyCollege (Attendance System).