Phone system is down
Resolved
This incident has been resolved.
Posted Aug 04, 2020 - 15:32 EDT
Update
We are continuing to investigate this issue.
Posted Aug 04, 2020 - 15:31 EDT
Update
We are continuing to investigate this issue.
Posted Aug 04, 2020 - 08:22 EDT
Investigating
We are currently investigating this issue.
Posted Aug 04, 2020 - 08:22 EDT
This incident affected: Phones (Cisco Voice and Unified Communications).