Outlook Performance Issues
Resolved
This incident has been resolved.
Posted Oct 10, 2024 - 15:21 EDT
Investigating
Users may notice Outlook using an increased amount of resource utilization, causing the client to freeze or crash.

We are working with the vendor to identify the issue.
Posted Oct 10, 2024 - 10:56 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 10, 2024 - 09:46 EDT
This incident affected: Microsoft Services (Outlook).