Print Anywhere Error
Resolved
This incident has been resolved.
Posted Dec 18, 2019 - 08:11 EST
Investigating
We are currently investigating an issue with the Print Anywhere system where users receive a "Failed to Connect" error message when trying to submit a print job.
Posted Dec 18, 2019 - 07:55 EST
This incident affected: Print AnyWhere.