MyCollege - Single Sign-on Unavailable

Resolved

The sign-in issue with My College has been resolved.
Posted Mar 10, 2025 - 13:31 EDT

Investigating

We are currently investigating this issue. You are still able to sign in using your username and password instead of your email address and password.
Posted Mar 10, 2025 - 08:41 EDT
This incident affected: MyCollege (Self Service, Web Advisor, Attendance System).