External Calling Issue

Resolved

The issue with external calling has been resolved.
Posted Sep 15, 2026 - 16:12 EDT

Identified

Due to a power outage, we are currently experiencing an issue affecting external phone calls. Internal calls are working, but users may be unable to make or receive calls to or from external numbers. Our technical teams are investigating, and updates will be provided as more information becomes available.
Posted Sep 15, 2026 - 15:24 EDT
This incident affected: Phones (Cisco Voice and Unified Communications).