Single Sign On Failure - Brightspace, Duo, My College Unavailable
Resolved
This incident has been resolved.
Posted Jul 18, 2024 - 19:01 EDT
Update
We are continuing to investigate this issue.
Posted Jul 18, 2024 - 18:26 EDT
Update
We are continuing to investigate this issue.
Posted Jul 18, 2024 - 18:21 EDT
Investigating
We are currently investigating this issue.
Posted Jul 18, 2024 - 18:08 EDT
This incident affected: MyCollege (Self Service, Web Advisor, Attendance System), Brightspace, and DUO Services (Duo SSO, Duo Core Authentication Service, Duo Push Delivery, Duo Admin Panel, Duo Phone Call Delivery, Duo SMS Message Delivery, Duo Cloud PKI).