Unplanned Outage - Cisco WebACD Online Chat Service
Resolved
WebACD in now back online. Unplanned outage has been resolved.
Posted Mar 14, 2021 - 10:42 EDT
Identified
We are experiencing an unplanned outage with Cisco WebACD. ITS is aware and looking into the issue.
Posted Mar 13, 2021 - 08:40 EST
This incident affected: WebACD.