Blackboard unavailable
Resolved
Blackboard is now available.
Posted Oct 25, 2019 - 08:09 EDT
Update
Be advised that Blackboard is currently down for all users. ITS is investigating the issue and will respond as soon as more information becomes available.
Posted Oct 25, 2019 - 07:26 EDT
Investigating
We are currently investigating this issue.
Posted Oct 25, 2019 - 06:23 EDT
This incident affected: Blackboard.